CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Fri Oct 18, 2019 8:11 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Feb 02, 2015 9:40 pm 
Offline

Joined: Mon Feb 02, 2015 7:44 pm
Posts: 2
I am using a Festo PLC w. Codesys v3. I am trying to connect to two temperature controllers that are Modbus RTU by using a Modbus TCP gateway (Antaira STM-501c). I set the PLC up as Modbus tcp master and attached two Modbus tcp slaves to it, each slave is set up with the gateway ip and the corresponding slave id. When doing this the bus becomes unstable and the connection to the slaves is lost. If I remove one slave from the configuration I have no problem connecting to either slave. It seems that the problem lies in the slaves both having the same ip. Although from what I have read it should not be a problem having to slaves with the same ip and different id's in the modbus standard. Has anyone encountered this and/or found a solution or workaround to this?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited