CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Wed Feb 26, 2020 10:27 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Apr 04, 2005 12:31 am 
Offline

Joined: Fri Apr 01, 2005 12:07 am
Posts: 8
Hi,

We have been using CoDeSys 2.3.1.4. I started looking at later service packs but have noticed a few issues (won't go into detail just yet). What is the offical stance on backwards compatibility ? I had a look on the website but could not find any information regarding this.

Thanks,
Michael.


Top
   
PostPosted: Thu Apr 07, 2005 10:45 am 
Offline
Site Admin
User avatar

Joined: Mon Jan 31, 2005 10:48 am
Posts: 237
Of course new versions of CoDeSys are backward compatible, so you can program your controller with the most recent version 2.3.4.1.

In the Customer Download Area on the 3S-Website you can download the Bug Report. Sometimes new versions or service packs caused problems because customers used fixed bugs as features :wink: . In case you work with the normal features there should not be any problem.

_________________
Roland Wagner
Moderator


Top
   
 Post subject:
PostPosted: Fri Apr 08, 2005 12:02 am 
I did try looking for the bug fix list when the new service pack was released but couldn't find it. Is this in protected download area ?

The problems I've experianced are basic things like the project simply not loading into the CoDeSys editor. I had not expected this to be a problem between minor version releases. As I was looking at newer versions, the installation of CoDeSys on my computer was more recent than my collegues.

I'll try to be brief.

We have been using version 2.3.1.4. This is the version all my collegues are using.

If I edit a project in version 2.3.3.6 then one of my collegues edits the same project in 2.3.1.4 that project then becomes corrupted.

Same test but with version 2.3.4.1. If I edit the project in the new version the project can no longer be opened by version 2.3.1.4. Attempts to do so cause a MS Visual C++ runtime library error "Assertion failed". Screen shot attached.

Is this something that should work or is this unsupported ?

Thanks,
Michael.


You do not have the required permissions to view the files attached to this post.


Top
   
 Post subject:
PostPosted: Fri Apr 08, 2005 12:52 pm 
Offline
Site Admin
User avatar

Joined: Mon Jan 31, 2005 10:48 am
Posts: 237
You can find the the bug fix list within the customer download area under http://www.3s-software.com/index.shtml?Down2 . In case you do not have the right passwort available please contact us under demo@3s-software.com.

The problem you describe is a real bug. I already passed it on to the 3S support hotline.

_________________
Roland Wagner
Moderator


Top
   
 Post subject:
PostPosted: Fri Apr 15, 2005 5:15 am 
Offline

Joined: Fri Apr 01, 2005 12:07 am
Posts: 8
Hi Roland,

Is this bug likely to be fixed in another service pack for CoDeSys 2.3 or are we limited to using version 2.3.1.4 ?

Thanks,
Michael.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited