CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sun Dec 08, 2019 11:30 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Jul 02, 2019 6:36 am 
Offline

Joined: Mon Nov 13, 2017 7:53 am
Posts: 15
Hello. I have difficulties to run the OPC server of my pigeon PLC (raspberry pi compute inside) with runtime 3.5.14.20.

The UaExpert windows "Add Server" :
see attachment n°3

The UaExpert windows error :
see attachment n°2

The Codesys log window:
see attachment n°1

I have a questions :
1) Which configuration file should I use?
Code:
"/etc/CODESYSControl_User.cfg" or "/etc/CODESYSControl.cfg"


2) What configuration in this file

Code:
[CmdOPCUA]
NetworkAdapter = eth0
NetworkPort = 4840


OU

Code:
[CmpOPCUAServer]
NetworkAdapter=eth0
NetworkPort=4840


3) What means the errors in Codesys log and UaExpert log ?

Thank you


Note:
When I do a Codesys Win V3 project, everything works.


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Wed Jul 03, 2019 5:42 am 
Offline

Joined: Mon Nov 13, 2017 7:53 am
Posts: 15
Hi. I found the solution.

In UaExpert OPC client, after add the server, display the properties of this server and replace the "EndPoint URL" :


opc.tcp://hostName:4840 by opc.tcp://IpAdress:4840

Now, it works


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited