CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sun Aug 18, 2019 6:20 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jun 02, 2019 11:21 pm 
Offline

Joined: Fri Aug 04, 2017 9:43 am
Posts: 2
hello,
I have added to the CNCdirect sample program from the tutorial (it works fine) with beckhoff hardware
-EK1000
-2x EL2512
Now I receive on P1 and P2 (SMC_ControlAxisByPos) a bError true signal
the parameter iErrorID says: SMC_MS_axis_in_errorstop

what is wrong?
Please advise

Holger


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Mon Jun 03, 2019 6:09 am 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3384
Hi,
SoftMotion does not work in simulation you could try to add the axis to 'SoftMotion general Axis pool'
and then login either to your Pi or you could SoftMotion Win on your CODESYS pc to login with your applicaiton.

BR
Edwin


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited