CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Thu Dec 13, 2018 4:38 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Dec 03, 2018 3:33 pm 
Offline

Joined: Sun Dec 02, 2018 7:19 am
Posts: 5
Hello everyone:
Thanks for this, when I control motor with codesys 3.5.9,I get a question of "SMC_DI_GENERAL_COMMUNICATION_ERR" at the time of Initializaing the 402axis in sync period of 8ms. and I find that if I set the period less than 8ms, just as 7ms, all things is ok, but when I set this value more than 8ms,then I get this error in Initialization phase.
Does anyboby have occured the same question?
Thanks again.


Top
   
PostPosted: Fri Dec 07, 2018 9:53 am 
Offline

Joined: Thu Aug 23, 2018 8:42 am
Posts: 29
Hi cookiy,

This is strange, I dont have a real answer but I would check the tasks' configurations. Is the initialization running under the fieldbus task? Or in a different one? I would prefer having everything running under the fieldbus task.

If fieldbus is Ethercat, are you using a distributed clock? Is this correctly set (also on the drive side).

Regards, Omar


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited