CODESYS - the IEC 61131-3 automation software
https://forum.codesys.com/

Cannot start config mode + position data from AKD
https://forum.codesys.com/viewtopic.php?f=6&t=9306
Page 1 of 1

Author:  cerminek [ Wed Nov 14, 2018 6:23 pm ]
Post subject:  Cannot start config mode + position data from AKD

Hello all,

I've just tried to start a config mode and it did not start due to errors, see bellow. Online works properly, drives can be controlled and they are moving. When new project were made with the same EtherCat devices, config mode can be started... Does anyone knows why?

Code:
 
[ERROR]         PROJECT: HiddenOnlineConfigModeApp [Device: PLC Logic]: C0077:  Unknown type: 'SM3_Basic.SMC_Commissioning_SM_Drive_ETC_Kollmorgen_AKD'
[ERROR]         PROJECT: C0035:  Program name, function or function block instance expected instead of '_Comm_SM_Drive_ETC_Kollmorgen_AKD.AfterReadInputs'
[ERROR]         PROJECT: C0077:  Unknown type: 'SM3_Basic.SMC_Commissioning_SM_Drive_ETC_Kollmorgen_AKD'



Second issue I have is position data from Kollmorgen AKD servodrive. There is no mechanical units set in servodriver, only Counts 16bit. The servo has SFD (2^24 increments) encoder. BUT the position values in Kollmorgen Workbench does not match to any position value in CoDeSys (scaling were disabled). Screens are in attachment...

Author:  cerminek [ Thu Nov 15, 2018 12:01 pm ]
Post subject:  Re: Cannot start config mode + position data from AKD

So small update. There is nothing about it in documentation BUT Kollmorgen AKD sends its position in 20bit resolution, in Kollmorgen WorkBench it is in 16bit value 'or 24bit as SFD encoder).

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/