CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sun Dec 16, 2018 11:26 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed Oct 24, 2018 5:54 pm 
Offline

Joined: Sat Oct 06, 2018 10:00 am
Posts: 7
Hello.

We are using SM3_Robotics library (4.3.0.0) with Codesys v3.5 sp10 to drive our 3d-gantry robot. We use an array of MC_MoveLinearAbsolute function blocks with blending option between the movements and it generally works fine, but on occasion the axis group gets shut down with the error SMC_CP_QUEUE_UNDERRUN. Upon receiving this error, when we reset the axis group and resend the movements, the movements are executed without any problem. Also when we look at the internal movement buffer of the axis group in the debugger mode, we can see that the movements are in there.

We want to understand why this happens, and how we can solve it.

Thanks in advance.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited