CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Sat Dec 16, 2017 3:50 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
 Post subject: MC_Stop question
PostPosted: Wed Sep 13, 2017 8:05 am 
Offline

Joined: Wed Apr 30, 2014 3:20 pm
Posts: 3
Hello.
The MC_Stop FB doesn't behave as it should.
1. When executed I get an Error.
2. I'm waiting for the axis to change state, therefore the Execute input is TRUE, and the outputs Done=FALSE, Error=TRUE.
3. For some unknown reason, although the MC_Stop is in this state, the axis does change its state to "stand still".
Pleas see attached images
How is that possible? What do I miss?
Thanks,
Alon.

Attachment:
XMC_STOP_I_O.JPG

Attachment:
XMC_STOP.JPG


You do not have the required permissions to view the files attached to this post.


Top
   
 Post subject: Re: MC_Stop question
PostPosted: Wed Sep 13, 2017 12:06 pm 
Offline
Frequent User
Frequent User

Joined: Wed May 04, 2016 6:00 pm
Posts: 180
Mc_stop not changes axe state with done to do that you have to put execute to false.

Use Mc_halt instead


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited