CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Mon Dec 09, 2019 9:54 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Nov 15, 2019 5:11 pm 
Offline

Joined: Thu Feb 15, 2018 5:03 pm
Posts: 26
Hi, Everyone

I found some problem with the SMC3_ReinitDrive Function Blocks. So when I execute this, It always keeps the state to busy.
It doesn't seem to be done.

Am I missing about this?

Please guide me on how to fix it.

With regards.


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Sat Nov 16, 2019 5:25 pm 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3564
Hi,
which drive is this?
I think you need to check the logger, there you should see why the slave hangs on startup.
(maybe could not switch ethercat op mode)

BR
Edwin


Top
   
PostPosted: Sat Nov 23, 2019 6:59 pm 
Offline

Joined: Thu Feb 15, 2018 5:03 pm
Posts: 26
Thanks, Edwin
The log of the device doesn't show any info for this problem.

The drive is Fuji Servo type: RYT101D5-VC2-Z88(EtherCAT)


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Wed Nov 27, 2019 9:16 pm 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3564
Hi,
is this drive DS402 compliant?
Then I would try to do it that way:
viewtopic.php?t=6254

If you add the ESI file I would check if this might possible.
BR
Edwin


Top
   
PostPosted: Thu Nov 28, 2019 10:32 am 
Offline

Joined: Thu Feb 15, 2018 5:03 pm
Posts: 26
Hi,
Edwin
The driver supports DSP402.

Attachment:
Untitled.png


I 've attached the XML file of the servo drive:

Attachment:
RYT-VC2-Z50_5000_0001.xml


if you need more information to solve this problem, please let me know

With Regards


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Fri Nov 29, 2019 3:59 pm 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3564
Hi,
with attached ESI it looks that way:


So my question is, where does it fail...
you could set:
SM3_BASIC_LOG_ACYCLIC_COM
as compiler define ( righclick on the application and add this as compiler define)
Then check the logger... in the situation it fails.

BR
Edwin


You do not have the required permissions to view the files attached to this post.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited