CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Sat Nov 18, 2017 5:19 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Nov 13, 2017 9:48 am 
Offline

Joined: Fri Dec 18, 2015 9:20 am
Posts: 18
Hello,

I have an application with two slaves drives (Ethercat Beckhoff EL7041) synchronized via MC_CamIn to a virtual master drive running in Time_Position_Profile.

I'm making some test under Codesys Control Win (not RTE for the moment).

The problem is that when the master as finished his position profile (stopped at his final position) , the slaves are still running slowly to their final position, like they were in late, not perfectly synchronized. :?

Should it be a problem due to Control Win instead of RTE, or some settings into the regulation loop ?

Thanks in advance.

Cedric


Top
   
PostPosted: Mon Nov 13, 2017 8:07 pm 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 2238
Hi,
hm...hard to say,
how do you use th drive, there is no SoftMotion driver available.

What about moven by simple MC_MoveAbs.. does this work?
BR
Edwin


Top
   
PostPosted: Wed Nov 15, 2017 7:44 pm 
Offline

Joined: Fri Dec 18, 2015 9:20 am
Posts: 18
Hi,

I'm using the drives as in the PosControl example project, sending velocity to the drives and actual positions as feedback.

I'm going to try a simple MC_MoveAbsolute command I see how does it work, I'll tell you.

Thanks


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited