CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Wed Jun 20, 2018 8:29 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon May 28, 2018 11:49 am 
Offline

Joined: Sat Apr 22, 2017 8:58 am
Posts: 19
Hello,

I am trying to control metronix servo motor via Raspberry Pi SL.
I tryed al mc blocks from SM3_BASIC library.And field bus was working,
fine without any errors.
But today i am recieving field bus error after 10 or 20 seconds i log in project.
And i didnt change anything from project that was working fine.
But today there is error from field bus(no synchronization via field bus).

I cant solve this problem
Can anyone help.
Thank you.


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Tue May 29, 2018 5:55 am 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 2709
Hi,
Did you apply a rt_preemt realtime kernel patch?
If not this will not work.
BR
Edwin


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited