CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Thu Sep 20, 2018 10:59 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Oct 06, 2017 4:21 pm 
Offline

Joined: Tue Oct 04, 2016 10:13 am
Posts: 26
Hello, i have a strange behavior with an janz tec emPC imx6 and i use the last codesys control 3.5.11.20 for it ,
i want some data exchange with an Schneider M251.
The behavior is :
read 1 holding reg - OK,
read n holding reg not working, all values are set zero...,
with an modbus tcp scaner modscan32 i can read well from M251,
In M251 i use builtin modbus server..
any suggestions??? please...


Top
   
PostPosted: Fri Oct 06, 2017 5:08 pm 
Offline

Joined: Tue Oct 04, 2016 10:13 am
Posts: 26
tried also on raspberry the same behavior :((


Top
   
PostPosted: Fri Oct 06, 2017 8:21 pm 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 2837
Hi,
Could you attach the project or at least screenshots?
Are you using the io varisbles in the pou's otherwise they will not be will updated.
BR
Edwin


Last edited by Edwin Schwellinger on Sun Oct 08, 2017 8:11 pm, edited 1 time in total.

Top
   
PostPosted: Sat Oct 07, 2017 7:51 am 
Offline

Joined: Tue Oct 04, 2016 10:13 am
Posts: 26
thank you Edwin now works.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited