CODESYS - the IEC 61131-3 automation software
https://forum.codesys.com/

Geteway
https://forum.codesys.com/viewtopic.php?f=21&t=9982
Page 1 of 1

Author:  Tiziano [ Sun Sep 08, 2019 1:15 pm ]
Post subject:  Geteway

Hi everyone, I have a problem with the gateway, the program has always worked but today the gateway does not connect to the raspberry even if it is connected and by pinging I can see it.
I have read the guide and I cannot understand if the gateway is active on my pc because I cannot find the symbol of the four squares and if they are on the list of programs and I click on codesys gateway I get the writing to look for the symbol of the four squares on the taskbar but I can't find it.
Can you tell me how can I restart the gateway?
Thank you

Author:  Edwin Schwellinger [ Mon Sep 09, 2019 8:58 am ]
Post subject:  Re: Geteway

Hi,
you need to check:

There should be two services up and running:
CODESYS ServiceControl
CODESYS Gateway V3

The Gateway Systray Icon you could start here:
"c:\Program Files\CODESYS 3.5.x.0\GatewayPLC\GatewaySysTray.exe"

If these two services are not registered in a proper way you could do this by (admin rights are needed for cmd and doing this):
"c:\Program Files\CODESYS 3.5.x.0\GatewayPLC\CoDeSysControlService.exe -i
"c:\Program Files\CODESYS 3.5.x.0\GatewayPLC\GatewayService.exe -i"

Working with the debug mode not as service ( as workaround)
"c:\Program Files\CODESYS 3.5.x.0\GatewayPLC\GatewayService.exe -d"

(Beside this you could add the Gateway which is embeeded in the CODESYS SL product - just use the IP of the plc )

BR
Edwin

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/