CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Fri Sep 20, 2019 9:58 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Sep 03, 2019 4:21 pm 
Offline

Joined: Mon Feb 18, 2019 1:18 pm
Posts: 16
Hello all,


I have Raspberry Pi connected to MCP2515. The CAN bus is terminated with a terminating resistance.
I have enabled the corresponding data overlays for Can bus. The status of the Can bus is "Running".
However, I have two situations:
1. The CANopen_Manager runs when I append it to CAN_Bus.
2. The CANopen_Manager fails as soon as I append a device. (The device fails too!) This is true with and without the actual physical device connected to the physical CAN bus.

Can somebody throw some light on this please?


Many thanks in advance!


Top
   
PostPosted: Tue Sep 03, 2019 4:58 pm 
Offline

Joined: Mon Feb 18, 2019 1:18 pm
Posts: 16
I tested the module with Janztec.
As soon as I append the device under CANopen_Manager on Janztec, it is detected and the CANopen_Manager turns green.


I am assuming that this is something to do with Raspberry Pi.

What am I missing out on? Kindly let me know.


Thanks again!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited