CODESYS - the IEC 61131-3 automation software
https://forum.codesys.com/

RaspberryPi Machine SL will not run (V3.5.15)
https://forum.codesys.com/viewtopic.php?f=21&t=9967
Page 1 of 1

Author:  Tbiddle [ Sun Sep 01, 2019 6:50 pm ]
Post subject:  RaspberryPi Machine SL will not run (V3.5.15)

The Run-time package seems to install fine, no errors in the messages section to indicate errors just that the system installed.

If you click on the System info button of the RaspberryPI tab in the Codesys application it will give you information in 3 of the 4 pane section of the popup, CPU Info, Network Info, Package Info, and nothing the Runtime Info section, it is completely blank.

It seems that the run-time is not being installed properly or at all. I am not really sure how to check the status of this. Has anyone experienced this?

Rapberry Pi 3, with fresh install of Stretch, and up to date
Codesys Installed on Windows 10, 1903

T

Author:  Edwin Schwellinger [ Sun Sep 01, 2019 7:20 pm ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

Hi,

you could login by ssh client ( putty for example)
and excute a
top
or
cat /tmp/codesyscontol.log

Keep in mind that predictable network interface names need to be disabled ( sudo raspi-config)
then paste the output of the two comands here.
BR
Edwin

Author:  Tbiddle [ Sun Sep 01, 2019 10:05 pm ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

There is no codesyscontrol.log in /tmp and there is no codesyscontrol service running when you look at top.

Author:  Edwin Schwellinger [ Mon Sep 02, 2019 8:49 am ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

Hi,
what happens on doing:

sudo /etc/init.d/codesyscontrol stop
followed by a
sudo /etc/init.d/codesyscontrol start

BR
Edwin

Author:  Tbiddle [ Mon Sep 02, 2019 4:06 pm ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

OK, so I have it up and running now. It seems that when I initially setup the pi I configured the interfaces to all be on (i.e. i2c, remote GPIO, One Wire, SPI, Camera).

Searching for a solution, I decided to shut them all off. From that point forward I was able to install down on the Pi, as well as scan, select, download, and run programs. I am not sure which one or group should not be enabled that caused this. Any info on this would be great.

Since getting this to work, I have tested this on the latest version of Stretch (Raspbian 9) and the latest version of Buster (Raspbian 10).

I am a very experienced Controls Engineer, not very familiar with Codesys, and not a linux expert. So much of this is platform is new me, any recommendations on the "Getting Started with Raspberry Pi and Codesys" document. I have seen the few user provided helpful tutorials.


Tracy

Author:  Edwin Schwellinger [ Tue Sep 03, 2019 7:31 am ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

Hi,
see the online help:
https://help.codesys.com/webapp/_rbp_f_ ... n=3.5.15.0

Additional attached the first steps documetnation which should be integrated in the online help if you prefer pdf's.

BR
Edwin

Author:  Tbiddle [ Tue Sep 03, 2019 2:40 pm ]
Post subject:  Re: RaspberryPi Machine SL will not run (V3.5.15)

Thanks Edwin! All this was very helpful.

Also I have narrowed the problems getting the Controlsys to start up on my raspbeerypi's both the stretch and the buster versions of the pi will not startup if "dtparam=i2c_arm=on" is in the boot config, or you have used Raspi-Config and enabled the i2c in the interface setup on the raspberrypi.

Tracy

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/