CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sat Feb 16, 2019 10:17 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun May 06, 2018 12:55 pm 
Offline

Joined: Fri Mar 06, 2015 1:34 pm
Posts: 2
Hello to all!
I'm trying to setup my Raspberry (Raspberry B+) as Modbus master TCP with a slave (ESP8266) but using a wifi dongle to create an access point and use wlan0 for communication.
Before doing this i have successful used modbus communication connecting the Raspberry and the slave under home router network. But now i need to use the network created by the Raspberry in order to have a standalone network.

First i have setup the dongle as AP with the ip 192.168.4.1 and it works fine, i'm able to connect the slave without problems.
In Codesys i have changed the interface used by TCP Master:

Image

And then the slave configuration:

Image

But the slave on the wlan0 side doesn't work.

Image

The project include web visualization and it works great connecting from a smartphone to the Pi's network (192.168.4.1:8080), i have no idea about reason the modbus doesn't work. The ip address is correct, tried the same configuration of the master and slave on eth0 interface and works like sharm, but not on wlan0.

Any help will be really appreciated
Many thanks
Alberto


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited