CODESYS - the IEC 61131-3 automation software
https://forum.codesys.com/

PI3 B+ MCP2515 CAN ERROR
https://forum.codesys.com/viewtopic.php?f=21&t=8463
Page 1 of 1

Author:  polygj [ Mon Jan 08, 2018 4:24 pm ]
Post subject:  PI3 B+ MCP2515 CAN ERROR

Can interface communication is all right in the terminal, but it is wrong in the codesys.
I have configured the can interface in the way in the forum, but the problem couldn't be solved.
I have no way to deal with the problem, please help !

Author:  Edwin Schwellinger [ Tue Jan 09, 2018 5:20 am ]
Post subject:  Re: PI3 B+ MCP2515 CAN ERROR

Hi,
is this 3.5SP12 Version?
Guess you need an entry in your /etc/CODESYSControl_User.cfg for example the following entry
where the script is located (this is like it is the beaglebone black done) :


[CmpSocketCanDrv]
ScriptPath=/opt/codesys/scripts/
ScriptName=rts_set_baud.sh

BR
Edwn

Author:  polygj [ Tue Jan 09, 2018 5:52 pm ]
Post subject:  Re: PI3 B+ MCP2515 CAN ERROR

Thank you very much! The problem seems to have been solved! And I'll test it in detail later.

Author:  Kalyani_K [ Thu Jul 18, 2019 2:46 pm ]
Post subject:  Re: PI3 B+ MCP2515 CAN ERROR

Hi there!

I am also trying to set up the same circuit as seen in the image attached by you.

Can you please tell me the steps(commands) to be taken to be able to set up can1?

I managed to set up can0 using the commands mentioned in the following link:
https://www.raspberrypi.org/forums/viewtopic.php?t=141052

I also changed the file pathway for the script as mentioned by Edwin.

However, I am now blind to be able to set up can1, such that two MCPs can run on a single raspberry pi.

It would be very helpful if you told me about what you did.

PS: I am not from Linux background.


Thanks again for your time!!

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/