CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sat Oct 19, 2019 3:25 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Wed Aug 06, 2014 9:23 pm 
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3494

Communication encryption for CODESYS WebVisu

In order to prevent communication from being hacked between a CODESYS compatible controller, which
supports the CODESYS WebVisu, and an internet browser on a PC or mobile device, an HTTPS connection
with encryption is available. It protects the integrity of the displayed data.

What is needed to publish a SSL encrypted Webvisualisation with the Raspberry Pi or any >= Version 3.5SP5 CODESYS plc?
For example you want to have access from internet to your home where your pi Webvisu is running

Sure for doing this you need a official ssl certificate and sure if you do not have a official certificate I would prefer a VPN connection additional
Passwort/UserManagement is needed in any case.
For testing purpose you could generate a ssl certificate to see how SSL Webvisu could be established/activated

On the pi runtime side you have the setting 'ConnectionType' in /etc/CODESYSControl.cfg


HTTP_ONLY, /* = 0 */ -->access your visu by http://RaspiIpAdress:8080/webvisu.htm
HTTPS_ONLY, /* = 1 */ -->access your visu by https://RaspiIpAdress:443/webvisu.htm gehen
HTTP_AND_HTTPS, /* = 2 */ -->access your visu by http://RaspiIpAdress:8080/webvisu.htm und https://localhost:443/webvisu.htm gehen
REDIRECT_HTTP_TO_HTTPS /* = 3 */ -->access your visu by http://RaspiIpAdress:8080/webvisu.htm will be redirected to https://localhost:443/webvisu.htm

for testing purpose you could generate on the pi a certificate by the following bash script (attached):
copy this to the pi (this could be done by CODESYS plc file browser) then connect by ssh (putty) to the pi
and execute the script (after make it executable by chmod +x ).
Generate process take some time, be patient.
After that long long key generation process and restart of the plc, you could connect by ssl encrypted connection to the Webvisu.

openssl genrsa -out server.key 2048
openssl req -new -key server.key -out server.csr
openssl x509 -req -sha256 -days 365 -in server.csr -signkey server.key -out server.crt
rm server.csr
openssl x509 -noout -in server.crt -fingerprint
openssl dhparam -outform pem -out dhparams.pem 1024
#copy the generated key to the runtime location
echo "make dirs"
mkdir /root/PKI
mkdir /root/PKI/cert
mkdir /root/PKI/crl
mkdir /root/PKI/private
mkdir /root/PKI/trusted
echo "move certificate"
mv server.crt /root/PKI/cert/server.cer
echo "move key"
mv server.key /root/PKI/private/
echo "move dhparams"
mv dhparams.pem /root/PKI/private/

Check the documentation here for more details:
"c:\Program Files (x86)\3S CODESYS\GatewayPLC\Documentation\WebServerSSL_en.pdf"

These steps are not needed anymore use the Security Agent from CODESYS Store to generate the certificates.

Best Regards

You do not have the required permissions to view the files attached to this post.

Last edited by Edwin Schwellinger on Sun Aug 11, 2019 8:44 am, edited 1 time in total.

PostPosted: Thu Jan 11, 2018 5:29 pm 

Joined: Tue May 19, 2015 6:27 am
Posts: 14
I tried this, created certificates, but without success (web page is redirected to https, but nothing is displayed)

---------Unable to connect
Firefox can't establish a connection to the server at "IP_ADDRESS"
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I tried setting connection back to 0 (ConnectionType=0), but web server is still redirecting to https!!!

Also PDF is not installed with V3.5 SP12 x64...


PostPosted: Fri Jan 12, 2018 8:27 am 

Joined: Tue May 19, 2015 6:27 am
Posts: 14
Some more problems & diagnosys.

1) I created OpenSSL certificate and I see it in /root/KPI directory. This is OK.
When I set .cfg file ConnectionType=3, web server redirects to https protocol. This works OK.
But when I reset ConnectionType=0 (set from 3 back to 0), webserver is allways (still) redirecting to https. With settings back to 0, only http protocol should be used, so resetting this setting doesn't work.
I also did system restart, without success. Still webserver redirects to https.

2) Then I installed security agent. I managed to create webserver certificate on the RPi. https redirection works, and now I got connection erorr: ERR_SSL_VERSION_OR_CIPHER_MISMATCH (both in FF and Chrome). In my knowledge this is a problem with certificate not beeing trusted, outdated technology ...
At least now I see connection to https protocol works and webserver on RPi knows where certificate is installed.

Once again I set ConnectionType back to 0. Still there is a problem of webserver allways redirects to https.

Best Regards,

PostPosted: Fri Jan 12, 2018 11:18 am 
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3494

yes this is an open point you need to execute:

cert-gendhparams 1024

in the plc Shell.
Then it will work at least with IE and Firefox.
It is an open point which need to be fixed.


PostPosted: Sat Jul 20, 2019 9:01 pm 

Joined: Tue Sep 18, 2018 2:34 am
Posts: 5
I have found that the PKI directory placed in /root will not allow the certificate and private key to load.

I have moved the entire PKI directory from /root/ to /var/opt/codesys/ and now the SSL certificate properly loads.

PostPosted: Sat Aug 10, 2019 4:15 pm 

Joined: Mon Apr 10, 2017 10:26 pm
Posts: 1
Hi is it possible to set ssl port in codesyscontrol.cfg?
CouldnĀ“t find any documents describing parameters an settings that can be done in the cfg file.
I have a webserver running on port 80,443 and would like to have webvisu ssl on port 8443


PostPosted: Mon Aug 12, 2019 1:31 pm 
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 3494

you could give this a try:



Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited