CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Sat Dec 14, 2019 11:31 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Jan 21, 2019 9:30 am 
Offline

Joined: Fri Jan 18, 2019 10:45 am
Posts: 3
Hello,

I want to use some tools from the codesys store (codesys SVN and codesys test manager). But these tools require a codesys version of "V3.5.9.50 or higher".
The manufacturer of the device I use, provides a Codesys development system in version V3.5.0.6.
Is it possible to download previous version of SVN and test manager compatibles with Codesys v3.5.0.6? Or what is it possible to do to use SVN and test manager with Codesys V3.5.0.6?

I will really appreciate your help :)

Best regards,

Lio


Top
   
PostPosted: Tue Jan 22, 2019 9:46 am 
Offline
Site Admin
User avatar

Joined: Mon Jan 31, 2005 10:48 am
Posts: 234
Hi,

in order to be able to download the add-on tools directly in CODESYS you need a higher version, which includes at least the CODESYS Package Package Manager. This function enables to install the add-on tools.

In case this is not possible you can nevertheless benefit from at least some of the add-on tools, e.g. the CODESYS Test Manager:
Download the latest version of the CODESYS Development System for free from the CODESYS Store: https://store.codesys.com/engineering/codesys.html. Furthermore, you can download, install and license the CODESYS Test Manager (see https://store.codesys.com/codesys-test- ... -demo.html) directly within the CODESYS Development System (there is a free demo license available).
Open the exisiting CODESYS project with this latest version and test your application code automatically by means of the add-on tool. It offers a dialogue based configuration, as well as unit tests by means of test source code or test tables. Ypu can use the results and work with them in the version from your device supplier.
Of course this is not the smoothest way of working, but in any case you have an option for doing so. Perhaps, you can even automation some of the steps by means of the integrated Python interface. This will work at least for the add-on tools Static Analysis and UML (at least for some parts of the functions) in the same way.

And of course it could make sense to motivate your device supplier to make an update. There are many, many new features and bugfixes included since V3.5.06, furthermore security vulnerabilities were closed, performance was increased etc.

_________________
Roland Wagner
Moderator


Top
   
PostPosted: Tue Jan 22, 2019 2:36 pm 
Offline

Joined: Fri Jan 18, 2019 10:45 am
Posts: 3
Thank you Roland for your answer.

I will have a look to the solution with the latest codesys and pyhton interface.
So no possibilities to download previous version of SVN and test manager?


Best regards,

Lio


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited