CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Wed Sep 26, 2018 4:25 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Feb 22, 2018 8:25 am 
Offline

Joined: Thu Feb 22, 2018 5:11 am
Posts: 1
I have an OPC server & a opc client in same Win7 PC with 20 VPB40 controllers configurations. Everything runs smooth. But when any one Controller goes off or shutdown or disconnected from network, then sometimes all PLC's gets disconnected from OPC, sometimes few PLC's gets disconnected and sometimes only respective PLC gets disconnected from OPC server. And other than actual disconnected plc, rest of them will get reconnected automatically. The OPC sever running version is 1.61.238.3 on both Controllers(xp) as well as PC. I have tried several timeout, wait time and re connection time configurations. But none are helping. Currently those are 5000, 30,30 respectively.

Below is the OPCLog

(22.02.2018, 14:19:59.332) **** ERROR: COMM_FATALERROR[0] from <PLC1>
(22.02.2018, 14:20:04.332) **** ERROR: Sync reading values failed from <PLC1>, Timeout expired
(22.02.2018, 14:20:04.363) **** ERROR: COMM_FATALERROR[0] from <PLC1>
(22.02.2018, 14:20:09.364) **** ERROR: Sync reading values failed from <PLC2>, Timeout expired
(22.02.2018, 14:20:14.378) **** ERROR: Sync reading values failed from <PLC6>, Timeout expired
(22.02.2018, 14:20:19.391) **** ERROR: Sync reading values failed from <PLC9>, Timeout expired
(22.02.2018, 14:20:24.408) **** ERROR: Sync reading values failed from <PLC15>, Timeout expired
.
.
(22.02.2018, 14:21:44.711) **** ERROR: HandleReply: **** PLC(4)=PLC2 is in unnormal state State=OCS_IDLE (OCS_IDLE)! ****
(22.02.2018, 14:21:44.711) **** ERROR: HandleReply: **** PLC(5)=PLC6 is in unnormal state State=OCS_IDLE (OCS_IDLE)! ****
(22.02.2018, 14:21:44.711) **** ERROR: HandleReply: **** PLC(10)=PLC9 is in unnormal state State=OCS_IDLE (OCS_IDLE)! ****
(22.02.2018, 14:21:44.711) **** ERROR: HandleReply: **** PLC(20)=PLC15 is in unnormal state State=OCS_IDLE (OCS_IDLE)! ****
.
.

Have you come across such issue? can anyone pls support?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited