CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Tue Oct 17, 2017 1:09 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed May 17, 2017 5:09 pm 
Offline

Joined: Thu Jan 26, 2017 5:00 pm
Posts: 16
In the VisualizationManger under the Visualizations tab there is a list of Visualizations that is generated. One of my visualizations is missing from the list and now when I press the button on my display to show the visualization it won't show and is stuck on the current screen.

The CurrentVisu variable shows that visualization is called but it does not display on the screen. This was working before and I believe it's not working now because the Visualization is not on the list in the VIsualizationManager. From what the online help section says, this list is generated by being referenced on other visualizations. I reference this visualization in structured text and it was working in the past so I don't know why it's not working now.

How do I edit that list to add my visualization back on to it?

EDIT: I fixed the issue. If anyone comes across this problem in the future double check the "Interface Editor" of the visualization if you have variables declared that are not used. Deleting the unused variable miraculously added the visualization back to the list in the VisualizationManager.

Attachment:
Capture.JPG


You do not have the required permissions to view the files attached to this post.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited