CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Thu Jul 27, 2017 1:29 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed May 17, 2017 3:04 pm 
Offline

Joined: Wed Dec 09, 2015 4:05 am
Posts: 31
Hi,

Does anyone have experience with Baumer MSAA servo drives ideally in Wago eCockpit?
When the nodes start up they go in pre op mode, but then when I set the CAN manager to auto start or send an NMT to start the node, the drive seems to reset after a very short period (few seconds). Any idea why a CAN drive would do that?

Kind Regards

Heinz

Sent from my SM-G935F using Tapatalk


Top
   
PostPosted: Fri May 19, 2017 4:43 am 
Offline
Site Admin

Joined: Mon Sep 05, 2005 9:42 am
Posts: 2015
Hello,

I'm not sure which options are available on eCockbit but I would play
with These Settings here:(screenshot)

BR
Edwin


You do not have the required permissions to view the files attached to this post.


Top
   
PostPosted: Fri May 19, 2017 7:06 am 
Offline

Joined: Wed Dec 09, 2015 4:05 am
Posts: 31
Same setting is available, I can now write and read SDOs and I receive the TPDOs.
Unfortunately the drive doesn't accept a new setpoint. It returns OK but when I read the target position back it stays on a certain value.
Hit another brick wall.

Sent from my SM-G935F using Tapatalk


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited