CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum
Deutsche Version English version russian version 
It is currently Tue Oct 17, 2017 1:11 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed Nov 16, 2016 9:49 am 
Offline

Joined: Mon Apr 11, 2011 9:29 am
Posts: 8
I have develop a library on C++ to control and monitor the PLC(Festo's CPX). I works very good (when it has proper connection).

Nevertheless I am experiencing a issue: sometimes the PLC does receive the messages (PC<-PLC), it is totally random, but once it starts working, it never fails while it is energized.
The work around is a power cycle, but it is annoying.

I have logged the UDP messages and I ca see that the messages are being broadcasted by the PC, but the PLC doesnt receive them. The PC->PLC communication always works

I got the idea from this project:
http://plclogger.sourceforge.net/index.php/en/

Has anyone experienced any issue like this?
Am i missing something?
How can I identify if this is HW issue or not? I happens with all the CPXs. Could it be a codesys RTE issue?

Thanks for your help

/Efrain


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited