CODESYS - the IEC 61131-3 automation software

Welcome to the official CODESYS Forum by 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
It is currently Thu Feb 27, 2020 9:03 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Apr 04, 2005 5:32 pm 
Offline

Joined: Mon Apr 04, 2005 5:07 pm
Posts: 3
Sorry, I am not sure that this is an appropriate forum for that kind of questions.

I have the tnf-file containing the following (our target ID value replaced with XXXXX).

[Targets]
Target1=fwio.trg,XXXXX
[Files]

In order to run the InstallTarget silently, I issue the following command from the bat-file:

"%CDSDIR%"\InstallTarget.exe d:\work\fwio\tsp\fwio.tnf /auto "%CDSDIR%\Targets\Fastwel"

where %CDSDIR% is an environment variable pointing to installtarget.exe location. The fwio.trg is located in d:\work\fwio\tsp\.

But this command doesn't install our target ("%CDSDIR%\Targets\Fastwel" remains empty).

Could anyone please suggest the correct way to silently run the InstallTarget utility (in particular, from installshield script)?

Thanks in advance.
Alexander Lokotkov


Top
   
PostPosted: Wed Apr 06, 2005 10:58 am 
Offline

Joined: Tue Feb 01, 2005 12:25 pm
Posts: 1
To use enviroment variables you need the InstallTarget.exe with version 1.1.0.0. It is part of the CoDeSys V2.3.4.1 setup.

The options of InstallTarget are:
<Path InstallTarget-exe> "<Path Info-file *.tnf>" /auto [<install directory>]

If you want to use it in a Batch-File, this works:
"%CDSDIR%\InstallTarget.exe" d:\work\fwio\tsp\fwio.tnf /auto %CDSDIR%\Targets\Fastwel
(note the missing quotation marks)

If you want to use it in an InstallShield script, this works:
szCommand = '"' + TARGETDIR ^ 'InstallTarget.exe"';
szCmdLine = '"' + szTNFFile + '" /auto ' + szInstallDir;
if (LaunchAppAndWait (szCommand, szCmdLine, WAIT) < 0) then
MessageBox(@ERROR_INSTALLTARGET, SEVERE);
endif;

I hope that helps,
Sabine Mack


Top
   
 Post subject:
PostPosted: Wed Apr 06, 2005 11:24 am 
Offline

Joined: Mon Apr 04, 2005 5:07 pm
Posts: 3
Thanks for your help. It works perfectly.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited